Impedir ingreso de datos repetitivos

0
1772

Cuántas veces hemos elaborado una lista con datos y sin querer hemos duplicado la información varias veces, ejemplo: productos o artículos (Código y Descripción), datos de personas (DNI, Apellidos y Nombres) y otros tipos de datos.

Esto lo podemos evitar utilizando la herramienta de Excel  Validación de datos el cual inclusive nos puede mostrar un mensaje de alerta indicándonos que estamos intentando ingresar un dato que ya esta ingresado anteriormente.

Veamos cómo se hace esto:

Tenemos el siguiente cuadro de productos o artículos, con dos campos Código y Descripción

DR 1

Necesitamos ingresar datos y que los mismos no se repitan.

El primer paso que tenemos que hacer, es seleccionar el rango (a nuestra elección) para este caso desde A4 hasta B12.

DR 2

A continuación seleccionamos el menú Datos,  y damos clic en Validación de datos

DR 3

En la ventana flotante, seleccionamos en el cuadro de lista Personalizada

DR 4

En el cuadro de fórmula ingresamos lo siguiente:

=CONTAR.SI($A$4:$B$12,A4)=1

Esta fórmula validará que solo se ingresen datos únicos en el rango de celdas seleccionadas.

DR 5

Pasamos a la pestaña Mensaje de error, y seleccionamos en el cuadro de lista Advertencia

DR 6

En el cuadro Título ingresamos: DATO REPETIDO

En el cuadro Mensaje de error ingresamos: Este dato ya existe en el listado.

Y por último damos clic en el botón Aceptar.

DR 8

Ahora si podemos ingresar nuestra información y evitar duplicar el código, la descripción o duplicar la descripción con diferentes códigos o duplicar el código con diferentes descripciones.

En el ejemplo estoy intentando ingresar el producto A con otro código «5», como ven Excel me muestra  un mensaje de alerta indicando que ya existe ese artículo en el listado.

DR 7

Espero les sea de mucha utilidad, hasta la próxima.

Dejar respuesta

Please enter your comment!
Please enter your name here